Website technical information

This website is designed to work with most web browsers for Windows and Mac operating systems. We recommend you always use the current browser version to ensure this website displays correctly, and so that you have the latest security updates.

Below is a list of recommended browsers and where to download them.

Supported Internet Browsers
Operating SystemRecommended Browser
Windows The latest version of
Microsoft Internet Explorer
Mozilla Firefox
Apple Safari
Google Chrome
Mac The latest version of
Mozilla Firefox
Apple Safari

Technical FAQs

Is a special connection required for Core Trader?

Core Trader is an internet-based application. A broadband connection is highly recommended; a 56k modem connection is the minimum.  You should contact your network administrator to confirm that access will be available.

Can I still use the website for trading?

Certainly — you can use either service at any time. When you are logged on to Core Trader, your website session will remain active, so you can switch easily between platforms. For example, you might access streaming market data via Core Trader while placing trades via the website.

Can I access Core Trader from any PC?

Yes, you can login from any computer that has an internet connection and the required operating standards and browser settings, wherever it is in the world. Please note that you can only login to Core Trader from one machine at a time.

What are the requirements for my computer?

To run Core Trader, you need:

  • A Pentium3 500MZH class machine with a minimum of 256MB RAM.
  • A network connection quality of a 56k modem or above — broad band is highly recommended.
  • Internet Explorer 6.0 or above, or Mozilla/Firefox.
  • Your browser needs to be Java enabled, with Sun Java 1.5.0_06 or above installed. You can download the most recent version from www.java.com
  • A colour monitor of at least 15”, with resolution great than 1024 X 768. We recommend a 17” colour monitor.
  • To run the Excel Add-in (DDE), you will need Microsoft Office Excel 2003 or later version.

Can I access Core Trader via a Mac?

Apple Mac is not officially supported by Core Trader, but users may access it via a later version of Mac OS X – Tiger, which permits Java applets to operate in the Safari browser .